EchoLink for iOS version 2.4.12 is now available

EchoLink for iOS version 2.4.12 is now available in the App Store. This is a 64-bit build that is fully compatible with iOS 10 and modern iOS devices. Requires iOS 8.0 or later.

Please note: This app is for licensed Amateur Radio operators only. See for more information.

EchoLink for iOS provides access to the EchoLink network for validated EchoLink users. You can use this app to connect to the EchoLink system from almost anywhere, using an iPhone, iPad, or iPod touch.

If you are not already a validated EchoLink user, you will be required to register (using your Amateur Radio callsign and a password of your choice) the first time you run the app. Please see the iPhone FAQ at

What’s New in version 2.4.12:

Added remote-PTT capability via earbud button. Improved screen layout for iPhone X. Fixed issue with audio-level meter. Fixed issue affecting login in Relay mode on some devices. Fix for issue with 2.3 on iOS 9.